Author Topic: epona1.4.7mod errors...  (Read 3714 times)

Offline Dave

  • First timer
  • *
  • Posts: 2
    • View Profile
epona1.4.7mod errors...
« on: October 26, 2001, 05:26:00 am »
Has anyone else compiled this version on freebsd 4.2 stable?

I'm getting these errors:


[[email protected] epona-1.4.7.mod]$ gmake
gmake: getcwd: : Permission denied
touch services.h
sh version.sh
gcc -O2 -Wall -g -c actions.c
gcc -O2 -Wall -g -c botserv.c
gcc -O2 -Wall -g -c channels.c
channels.c:333: `check_valid_halfop' undeclared here (not in a function)
channels.c:333: initializer element is not constant
channels.c:333: (near initialization for `cumodes[104].is_valid')
gmake: *** [channels.o] Error 1
[[email protected] epona-1.4.7.mod]$



Any Ideas?



Offline ShadowMaster

  • Chief Codemonkey
  • Administrator
  • ********
  • Posts: 3136
    • View Profile
    • http://www.shadow-realm.org/
epona1.4.7mod errors...
« Reply #1 on: October 26, 2001, 03:50:00 pm »
This is caused by a minor oversight which isnt important unless you try and compile the modded epona for something other than UltimateIRCd3.0.0 which is the only reason to use the modded version in the first place :smile:

Select ircdtype 6 during configure, or grab the standard epona if you dont use UltimateIRCd 3.0.x
Search before posting - No support by PM or IM

Offline Dave

  • First timer
  • *
  • Posts: 2
    • View Profile
epona1.4.7mod errors...
« Reply #2 on: October 26, 2001, 04:48:00 pm »
Thanks! I was compiling it for 2.8.2, go figure... lol

Offline PilotinControl

  • Here a lot
  • ***
  • Posts: 65
    • View Profile
    • http://www.publiclinux.net
epona1.4.7mod errors...
« Reply #3 on: November 04, 2001, 01:47:00 am »
I was wondering is there a way to tranfer data-bases from one version of irc services to another i am trying to take data from Au:badword:e services and adding them to the epona-1.4.7 services or vices versa can that be done? I cant seem to get any answers from anyone - Thank You
" When In Doubt.....DUCK You SHMUCK!!"

Offline ShadowMaster

  • Chief Codemonkey
  • Administrator
  • ********
  • Posts: 3136
    • View Profile
    • http://www.shadow-realm.org/
epona1.4.7mod errors...
« Reply #4 on: November 04, 2001, 01:49:00 am »
Well, yes it is possible, but it requires a database convertion tool in order to convert the Au:badword:e data format in this case into something epona can understand. I have no knowledge of such a converter exsisting as of today, although its not impossible someone have written one.
Search before posting - No support by PM or IM

Offline PilotinControl

  • Here a lot
  • ***
  • Posts: 65
    • View Profile
    • http://www.publiclinux.net
epona1.4.7mod errors...
« Reply #5 on: November 04, 2001, 04:30:00 am »
thanx you very much =-) it was worth a try
" When In Doubt.....DUCK You SHMUCK!!"

 

anything