Userfriendly

Recent Posts

Pages: 1 2 3 [4] 5 6 ... 10
31
UltimateIRCd 3.0 Support / Re: gcc question
« Last post by thepitster on October 14, 2009, 01:54:01 am »
got a similar problem here gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4)
and i get compilation errors every where, same thing i guess goto UB forums and find a fix ......
32
UltimateIRCd 3.0 Support / Re: local users: 1 Max: 1 <--- cant change it and global ????
« Last post by x90 on October 05, 2009, 02:33:35 am »
i connected as normal user from my box , then i connected with root account , and it said this ->
 ERROR Closing Link: 0.0.0.0 (No more connections allowed in your
 connection class (the server is full))
14:33 -!- Irssi: Connection lost to 127.0.0.1
33
UltimateIRCd 3.0 Support / Re: local users: 1 Max: 1 <--- cant change it and global ????
« Last post by will on October 05, 2009, 02:31:12 am »
Have you actually tried connecting a second user?

Ussually, the place where that is displa:badword:. It's just runtime information. Users: 1 is how many there are now, and Max: 1 is the maximum there HAS been since the last restart. The max should raise as soon as you have two users at once on your server.

Try it. =P

-Will
34
UltimateIRCd 3.0 Support / local users: 1 Max: 1 <--- cant change it and global ????
« Last post by x90 on October 05, 2009, 01:57:15 am »
I only 1 client can connect to my server. i tried ./configure ./configure --with-maxclients=1000.
but i still get the same problem, I ran ulimit -n 5000 , and still the same problem.

heres my ircd.conf

P:127.0.0.1:::6667
I:*@*::*@*::1
Y:1:90:0:5000:100000
M:localhost:127.0.0.1:localhost:6667

running arch linux.
35
UltimateIRCd 2.8-Win32 Support and Discussion / Winblows Vista
« Last post by D34D on August 08, 2009, 08:53:09 pm »
My Comp Stats:
OS: Windows Vista Home Edition 6.0 SP1 (Build #6001) CPU: AMD Athlon 64 X2 Dual Core 4000+, 2.11 GHz, 512KB Video: NVIDIA GeForce 6150SE nForce 430 (1440x900x32bpp 60Hz) Sound: Speakers (Realtek High Definition Audio) Memory: Used: 817/1918MB Uptime: 27m 1s HD: Free: 197.14 GB/298.09 GB

My Version of UltimateIRCd:
UltimateIRCd(Tsunami)-3.0(01)-Win32 chaos-realm.gotdns.com RelStatus=RELEASE ServOpts=CiI(TS5ow) Proto=3000

I have downloaded, installed and configured everything and the IRCd works perfectly except when I goto connect services. They will connect for a split second and then UltimateIRCd.exe crashes without warning but, However, It works just dandy on a Windows XP SP3 laptop. I do not see what's wrong here I have tested everything
36
UltimateIRCd 3.0 Support / Segfault on Disconnect
« Last post by SunOS on July 24, 2009, 04:44:46 am »
When i disconnect from the server, It causes this...

Program received signal SIGSEGV, Segmentation fault.
close_connection (client_p=0x7f2700000000) at s_bsd.c:1358
1358        local[client_p->fd] = NULL;
(gdb) backtrace full
#0  close_connection (client_p=0x7f2700000000) at s_bsd.c:1358
        aconf = <value optimized out>
#1  0x0000000000430f86 in exit_client (client_p=0x7f2730ad9838, source_p=0x7f2730ad9838, from=0x7f2730ad9838,
    comment=0x7fff38c30ec0 "Client exited") at s_misc.c:843
        on_for = <value optimized out>
        logfile = -1
        lasttime = 1248395940
#2  0x0000000000446b44 in m_quit (client_p=0x7f2730ad9838, source_p=0x7f2730ad9838, parc=<value optimized out>, parv=<value optimized out>)
    at s_user.c:3007
        reason = <value optimized out>
        comment = "Client exited\000\000\0000\017Ã8ÿ\177\000\000Ä\231­0?", '\0' <repeats 11 times>, "8\230­0'\177\000\0008\230­0'\177\000\000`i~\000\000\000\000\000S\002\202\000\000\000\000\000àöD\000\000\000\000\000\020\000\000\0000\000\000\000ð\017Ã8ÿ\177\000\0000\017Ã8ÿ\177\000\000S\002\202\000\000\000\000\000Ë\230­0'\177\000\000Ð\017Ã8ÿ\177\000\000S\002\202\000\000\000\000\000S\002\202\000\000\000\000\000Å\231­0'\177\000\000        À\231­0\000\000\000\000Ë\230­0'\177\000\000S\002\202\000\000\000\000\000:\000\000\000\000\000\000\000ç\226­0'\177\000\000\035"...
#3  0x0000000000420925 in client_dopacket (client_p=0x7f2730ad9838, buffer=<value optimized out>, length=0) at packet.c:260
No locals.
#4  0x0000000000424c6e in do_client_queue (client_p=0x7f2730ad9838) at s_bsd.c:1940
        dolen = 0
        done = <value optimized out>
#5  0x0000000000426260 in readwrite_client (client_p=0x7f2730ad9838, isread=1, iswrite=0) at s_bsd.c:2257
        length = <value optimized out>
#6  0x000000000045278d in engine_read_message (delay=<value optimized out>) at socketengine_poll.c:187
        rr = 0
        rw = 0
        pfd = (struct pollfd *) 0x7edf78
        nfds = 0
        i = 7
        fdflags = 1
        fdtype = 0
        fdvalue = (void *) 0x7f2730ad9838
        client_p = (aClient *) 0x3ed
        poll_fdarray = {{fd = 1, events = 25, revents = 0}, {fd = 4, events = 25, revents = 0}, {fd = 5, events = 25, revents = 0}, {fd = 6,
    events = 25, revents = 0}, {fd = 7, events = 25, revents = 0}, {fd = 3, events = 25, revents = 0}, {fd = 8, events = 25, revents = 0}, {
---Type <return> to continue, or q <return> to quit---
    fd = 9, events = 25, revents = 1}, {fd = 10, events = 29, revents = 0}, {fd = 0, events = 0, revents = 0} <repeats 1015 times>}
#7  0x0000000000418dd8 in io_loop () at ircd.c:1618
        to_send = "@\025Ã8ÿ\177\000\000\f\026Ã8ÿ\177\000\000\030\000\000\0000\000\000\000 \026Ã8ÿ\177\000\[email protected]\025Ã8ÿ\177\000\000°tÂ0'\177\000\000\000\000\000\000\000\000\000\000ÿÿÿÿ\000\000\000\000\207\f\000\000\000\000\000\000Pñ\0210'\177\000\000responseÿþþþþþþ~í\003\000\000\000\000\000\000í\003", '\0' <repeats 14 times>, "Ê!¢0'\177\000\000\001\000\000\000ÿ\177\000\000\000\000\000\000\000\000\000\000?\000\000\000\000\000\000\000À\000\000\000\000\000\000\000ÐK\0060'\177\000\000\b", '\0' <repeats 15 times>, "\022\200¢0'\177\000\000\b\000\000\000\000\000\000"
        lasttime = 1248395933
        lastrecvK = 2
        lrv = <value optimized out>
        lastbwcalc = 1248395937
        lastbwSK = 5
        lastbwRK = 2
        lasttimeofday = <value optimized out>
        delay = <value optimized out>
#8  0x000000000041a0ea in main (argc=0, argv=0x7fff38c31840) at ircd.c:1343
        uid = 1005
        euid = 1005
        portarg = 0
        fd = <value optimized out>
        mcsfp = <value optimized out>
        star = "*"
37
UltimateIRCd 3.0 Support / Re: Mulitple Ports
« Last post by openProxy on June 23, 2009, 03:19:34 am »
Code: [Select]
P:*::6665
P:*::6666
#P:*::6667
P:*::6660
P:*::6661
P:*::6662
P:*::6663
P:*::6664
P:*::6668
P:*::6669
#P:*::7000
P::*:SSL:9999
^ that's what I have in my config.. do I put the ip in place of the * ?
38
UltimateIRCd 3.0 Support / Re: Mulitple Ports
« Last post by ShadowMaster on June 22, 2009, 03:20:51 pm »
You will need to specify each port individually using P lines in your ircd.conf. All available ports is unviable as it would require the IRCd to open more ports than the system would allow (65k+ ports).
39
UltimateIRCd 3.0 Support / Mulitple Ports
« Last post by openProxy on June 20, 2009, 06:16:04 am »
I have UltimateIRCd compiled and setup and running I want it run on 6660-6669 but I have it set to 6668 how do I do all avaliable ports? if you could help it would be greatly appreciated :)
40
UltimateIRCd 3.0 Support / Re: Channel Modes issue
« Last post by ShadowMaster on June 02, 2009, 07:16:36 pm »
Finals over with at last.

Is there any chance i could get access to a shell on the system where this problem manifests itself?
Pages: 1 2 3 [4] 5 6 ... 10
SimplePortal 2.3.7 © 2008-2021, SimplePortal