Userfriendly

Author Topic: Latest 3.1 version hangs up due to some ircd.ini settings  (Read 3836 times)

Offline CosmicD

  • First timer
  • *
  • Posts: 6
    • View Profile
Latest 3.1 version hangs up due to some ircd.ini settings
« on: June 06, 2005, 12:57:15 pm »
Hello,

Yesterday I've installed the latest svn build of ultimate 3.1. Upon compiling (and start) it just sits there without letting anyone in ,

Am i missing something ? I spent the better part of the night deleting, reinstalling, I even used bare settings to act as if I start over with a new server (without my own configs) and it starts, yet it just doesn't let anyone in..

I'm gonna do a testland version on another account/ip today , the thing is that it just doesnt show anything in the logs..  it says it starts logging everything there is to log but thats about it..... the daemon is just a demon :)

UPDATE:

I've found the problem settings. I was using the same ini version as that of the previous 3.1 8xx (dont remember exactly the build) version. After testing I've identified the problemsettings t hat cause the ircd to hang when you configure them:

Code: [Select]

# Log critical IRCd errors, warnings and startup messages (recommended)
Set log_lcritical ..............: 0

# Log local client connects, exits and other client related messages
Set log_lclients ...............: 0


When setting the "log_lcritical" setting to 1, and the "log_lclients" to 0 , the server will just start up but dont respond to any incomong clients.

When setting the "log_lcritical" to 0, and the "log_lclients" to 1 , the server will startup and clients will se no motd

When doing 1:1 settings, its the same effect as when you put the logcritical setting to 1

When disabling both settings (or commenting them out) the server starts correctly

The onwerrights all semm ok becasue theres a log folder with different files that all have 700 and they are being written to

Could that be that I miscompile something ?  I think I've enabled debugmode too, but without any effect....

Offline ShadowMaster

  • Chief Codemonkey
  • Administrator
  • ********
  • Posts: 3135
    • View Profile
    • http://www.shadow-realm.org/
Latest 3.1 version hangs up due to some ircd.ini settings
« Reply #1 on: June 07, 2005, 04:59:02 pm »
This looks like a genuine bug.

Me or Radiant will have to look into this. Not sure when i can get to it atm.
Search before posting - No support by PM or IM

Offline ShadowMaster

  • Chief Codemonkey
  • Administrator
  • ********
  • Posts: 3135
    • View Profile
    • http://www.shadow-realm.org/
Re: Latest 3.1 version hangs up due to some ircd.ini settings
« Reply #2 on: October 24, 2005, 04:23:06 am »
Small bump to this one for my own benefit.
Search before posting - No support by PM or IM

Offline ShadowMaster

  • Chief Codemonkey
  • Administrator
  • ********
  • Posts: 3135
    • View Profile
    • http://www.shadow-realm.org/
Re: Latest 3.1 version hangs up due to some ircd.ini settings
« Reply #3 on: October 24, 2005, 05:22:11 am »
Ok. Some brief testing and ive been able to reproduce this quite easilly.
Seems there are some issues with File Descriptor handeling offhand. Going to take a closer look at this, hopefully tomorrow.
Search before posting - No support by PM or IM

 

anything
SimplePortal 2.3.7 © 2008-2021, SimplePortal